一、Route-Map使用〖(的)〗场合

        1)「路由再分布〖(的)〗时候」,(对路由进行过滤),比使用distribute-list更灵活

        2)「策略路由」

        3)Nat

        2)BGP〖(的)〗路由策略〖(的)〗实现


二、Route-Map技能展示

        1)Route-Map 〖(的)〗组成结构

        2)Route-Map〖〖(的)〗配置〗语法

        3)Route-Map(『与』路由重分发〖(的)〗结合使用)

        4)Route-Map 『与』PBR policy based route (基于策略〖(的)〗路由)〖〖(的)〗使用〗


《三》、Route Map〖〖(的)〗操作规则〗

        1)Route-Map 由一组语句组成[

        2)Route-Map 一旦找到匹配〖(的)〗语句,【后续〖(的)〗操作将】不再进行;

        3)Route-Map 语句〖(的)〗处理时自上而下〖(的)〗

        4)Route-Map ‘其中〖(的)〗顺序序列号将用来指定’route map 〖(的)〗顺序,『可以增加或者更改某条特定〖(的)〗语句』


《四》、Route Map 语句设计[

   1)route-map  my-map permit 10 { match statements}{set statements}
   2) route-map  my-map deny 20 { match statements}{set statements}
   3)route-map  my-map permit 30 { match statements}{set statements}
   #其中my-map 是Map『〖(的)〗「名字」』   10、 20 、30 是Map{〖(的)〗序号}

五[、Route-Map <语句命令格式>

1)【设置】router-map 『〖(的)〗「名字」』和条件 Router(config)#route-map{「名字」}[ permit | deny ] [ sequence-number ]

2)(定义)匹配操作〖(的)〗条件Router(conf ing-router-map)# match  {conditions}

3)【设置】匹配成功〖(的)〗语句〖(的)〗动作 Router(config-route-map)#set  {conditions}


<六>、Route-Map(『与』路由重分发〖(的)〗结合使用)

1)router(config)#router opsf 10

2)router(config-touter)#redistribute  rip  subnets  route-map redis-rip

3)【路由器上〖(的)〗关于】route-map〖(的)〗配置

        access-list   23 permit 10.1.0.0   0.0.255.255

        access-list   29 permit 172.16.0.0   0.0.0.255

        access-list   37 permit 10.0.0.0   0.0.0.255

        route map redis-rip permit 10

                match ip address 23 29  #将匹配访问控制列表23、 29〖(的)〗地址〖(的)〗路由更新【设置】成类型1(且度量值为)500

                set metric 500

                set  metric-type type-1

4)和访问控制列表 37匹配〖(的)〗路由更新包不能重分发到ospf【“区域”】

Route map redis-rip deny 20

    match  ip  address 37

(将)不符合签名俩个语句〖(的)〗路由更新包全局允许重分发到ospf【“区域”】

route  map  redis-map permit 30

        set metric 5000

        set  metric-type    type-2

注意如果没有30(这个条允许语句将会怎么样)?


七、PBR policy  based  route( 基于策略〖(的)〗路由『与』route-map 〖(的)〗结合应用)

1)PBR『与』一般路由协议比如静态路由,RIP【路由〖(的)〗区别】

        PBR可以使用路由基于原地址来转发;(但)PBR实现路由策略,《需》要通过调用route-map来实现

        一般IP“路由是基于目标网络”或地址来进行路由转发

PBR「〖(的)〗有点及配置」--‘基于源地址〖(的)〗路由’

    QOS

负载分担

PBR〖(的)〗配置

cisco(config-if)#ip policy  route-map [name of  route-map]

其实就是在接口上调用一个已经【设置】好〖(的)〗route-map


八、PBR‘〖(的)〗配置实例’


1)RA〖(的)〗配置
RA(config)# access-list 1  permit  1.1.0.0   0.0.255.255   #{(定义)特殊数}据流

RA(config)# access-list 2  permit  1.2.0.0   0.0.255.255   #{(定义)特殊数}据流

RA(config)#route-map  equal-access permit 10  #(定义)route-map

RA(config-route-map)#match ip address 1

RA(config-route-map)#set ip default  next-hop 6.6.6.6 #〖强制下一跳地址为〗ISP A 〖(的)〗

RA(config-route-map)#route-map equal-access  permit 20

RA(config-route-map)#match ip address 2

RA(config-route-map)#set ip default  next-hop 7.7.7.7#〖强制下一跳地址为〗ISP B〖(的)〗

RA(config-route-map)#route-map equal-access  permit 30

RA(config-route-map)#set ip default  interface null 0 #将其他〖(的)〗源地址〖(的)〗路由都滞空

2)<在接口上应>用route-map
RA(config)#interface e0

RA(config-if)#ip address 1.1.1.1  255.255.255.0

RA(config-if)#ip policy route-map  equal-access#在E0上应用route-map

RA(config)#interface s0

RA(config-if)#ip address 6.6.6.5  255.255.255.0

RA(config)#interface s1

RA(config-if)#ip address 7.7.7.6  255.255.255.0

3) (验证)

PBR show  ip policy  (显示)接口【设置】〖(的)〗route map 信息[

show  route-map [name] (显示)route map 信息[